summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index b076ad20129..3cad882f947 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3027,9 +3027,13 @@ AC_ARG_WITH(gc,
[ --with-gc={page,zone} choose the garbage collection mechanism to use
with the compiler],
[case "$withval" in
- page | zone)
+ page)
GGC=ggc-$withval
;;
+ zone)
+ GGC=ggc-$withval
+ AC_DEFINE(GGC_ZONE, 1, [Define if the zone collector is in use])
+ ;;
*)
AC_MSG_ERROR([$withval is an invalid option to --with-gc])
;;