summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 3cad882f947..dedb8002970 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1332,6 +1332,13 @@ if test -n "$extra_modes" && test -f $srcdir/config/$extra_modes; then
for this architecture.])
fi
+# Convert extra_options into a form suitable for Makefile use.
+extra_opt_files=
+for f in $extra_options; do
+ extra_opt_files="$extra_opt_files \$(srcdir)/config/$f"
+done
+AC_SUBST(extra_opt_files)
+
# auto-host.h is the file containing items generated by autoconf and is
# the first file included by config.h.
# If host=build, it is correct to have bconfig include auto-host.h
@@ -1525,8 +1532,8 @@ AC_SUBST(host_cc_for_libada)
out_object_file=`basename $out_file .c`.o
-tm_file_list=
-tm_include_list=
+tm_file_list="options.h"
+tm_include_list="options.h"
for f in $tm_file; do
case $f in
defaults.h )