summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 71f6f0d49a0..36068563972 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -513,6 +513,15 @@ fi
AC_SUBST(valgrind_path_defines)
AC_SUBST(valgrind_command)
+AC_ARG_ENABLE(mapped-location,
+[ --enable-mapped-location location_t is fileline integer cookie],,
+enable_mapped_location=no)
+
+if test "$enable_mapped_location" = yes ; then
+ AC_DEFINE(USE_MAPPED_LOCATION, 1,
+[Define if location_t is fileline integer cookie.])
+fi
+
# Enable code coverage collection
AC_ARG_ENABLE(coverage,
[ --enable-coverage[=LEVEL]