summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index a1a016cf082..f101f494177 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -271,6 +271,14 @@ if test x$TARGET = xX86 || test x$TARGET = xX86_WIN32 || test x$TARGET = xX86_64
fi
fi
+case "$target" in
+ *-apple-darwin10* | *-*-freebsd* | *-*-openbsd* | *-pc-solaris*)
+ AC_DEFINE(FFI_MMAP_EXEC_WRIT, 1,
+ [Cannot use malloc on this target, so, we revert to
+ alternative means])
+ ;;
+esac
+
AC_CACHE_CHECK([whether .eh_frame section should be read-only],
libffi_cv_ro_eh_frame, [
libffi_cv_ro_eh_frame=no