summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index 1c405e8dfe5..48fd5b9abc1 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -403,16 +403,13 @@ esac
# Used for constructing correct paths for offload compilers.
accel_dir_suffix=
+real_host_noncanonical=${host_noncanonical}
if test x"$enable_as_accelerator_for" != x; then
accel_dir_suffix=/accel/${target_noncanonical}
- case "${target_noncanonical}" in
- *-intelmicemul-*)
- # In this case we expect offload compiler to be built as native, so we
- # need to change install directory for driver to be able to find libgcc.
- host_noncanonical=${enable_as_accelerator_for} ;;
- esac
+ real_host_noncanonical=${enable_as_accelerator_for}
fi
AC_SUBST(accel_dir_suffix)
+AC_SUBST(real_host_noncanonical)
if test x"$enable_offload_targets" != x; then
extra_parts="${extra_parts} crtoffloadbegin.o crtoffloadend.o"