summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index d6180bcddd9..3380819ab3a 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -236,6 +236,12 @@ if [[ "${shared}" != "yes" ]]; then
fi
AC_SUBST(PICFLAG)
+NOASANFLAG=
+case " ${CFLAGS} " in
+ *\ -fsanitize=address\ *) NOASANFLAG=-fno-sanitize=address ;;
+esac
+AC_SUBST(NOASANFLAG)
+
echo "# Warning: this fragment is automatically generated" > temp-frag
if [[ -n "${frag}" ]] && [[ -f "${frag}" ]]; then