summaryrefslogtreecommitdiff
path: root/libio/tests/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libio/tests/configure.in')
-rw-r--r--libio/tests/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/libio/tests/configure.in b/libio/tests/configure.in
index 2efeaf52565..1a8ad31ae92 100644
--- a/libio/tests/configure.in
+++ b/libio/tests/configure.in
@@ -17,7 +17,18 @@ XCINCLUDES='-I. -I.. -I$(srcdir) -I$(srcdir)/..'
XCXXINCLUDES='-I. -I.. -I$(srcdir) -I$(srcdir)/..'
MOSTLYCLEAN='*.o core $(JUNK_TO_CLEAN)'
(. ${srcdir}/../config.shared) >${package_makefile_frag}
-if [ ! -d ${srcdir}/../../gcc ] ; then
+
+if [ "${srcdir}" = "." ] ; then
+ if [ "${with_target_subdir}" != "." ] ; then
+ topsrcdir=${with_multisrctop}../../..
+ else
+ topsrcdir=${with_multisrctop}../..
+ fi
+else
+ topsrcdir=${srcdir}/../..
+fi
+
+if [ ! -d ${topsrcdir}/gcc ] ; then
echo "CHECK = check-iostream check-iostdio" >>${package_makefile_frag}
fi