summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 0e7d91a8042..9841f60c4af 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -454,12 +454,9 @@ if USE_LIBGCJ_BC
rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.la;
endif
if BUILD_ECJ1
-if NATIVE
+## Undo any prepending of the target prefix and transform
+## to the actual host's executable suffix.
mv $(DESTDIR)$(libexecsubdir)/`echo ecjx | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(libexecsubdir)/ecj1$(host_exeext)
-else !NATIVE
-## Undo the prepending of the target prefix
- mv $(DESTDIR)$(libexecsubdir)/$(target_noncanonical)-`echo ecjx | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(libexecsubdir)/ecj1$(host_exeext)
-endif !NATIVE
endif BUILD_ECJ1
## Install the headers. It is fairly ugly that we have to do this by