summaryrefslogtreecommitdiff
path: root/libobjc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libobjc/configure.in')
-rw-r--r--libobjc/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/libobjc/configure.in b/libobjc/configure.in
index 2f748983103..a3930bf88a7 100644
--- a/libobjc/configure.in
+++ b/libobjc/configure.in
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 1995, 1997, 1998, 1999 Free Software Foundation, Inc.
+# Copyright (C) 1995, 1997, 1998, 1999, 2002 Free Software Foundation, Inc.
# Contributed by Dave Love (d.love@dl.ac.uk).
#
#This file is part of GNU Objective C.
@@ -23,6 +23,12 @@ AC_PREREQ(2.13)
AC_INIT(objc/objc.h)
AC_CONFIG_HEADER(config.h)
+# This works around the fact that libtool configuration may change LD
+# for this particular configuration, but some shells, instead of
+# keeping the changes in LD private, export them just because LD is
+# exported.
+ORIGINAL_LD_FOR_MULTILIBS=$LD
+
AC_CANONICAL_SYSTEM
target_alias=${target_alias-$target}
AC_SUBST(target_alias)
@@ -123,6 +129,7 @@ if test -n "$CONFIG_FILES"; then
if test -n "${with_target_subdir}"; then
# FIXME: We shouldn't need to set ac_file
ac_file=Makefile
+ LD="${ORIGINAL_LD_FOR_MULTILIBS}"
. ${toplevel_srcdir}/config-ml.in
fi
fi],