From 3b7b1092bc50d9042b9cb6e26c479cc8c0dd2150 Mon Sep 17 00:00:00 2001
From: ro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>
Date: Fri, 17 Feb 2012 13:38:15 +0000
Subject: Disable gthreads on Solaris 8/9 (PR libstdc++/52189)

	PR libstdc++/52189
	* acinclude.m4 (GLIBCXX_CHECK_GTHREADS): Handle
	--enable-libstdcxx-threads.
	Disable on Solaris 8/9 with symbol versioning.
	* configure.ac (GLIBCXX_CHECK_GTHREADS): Move after
	GLIBCXX_ENABLE_SYMVERS.
	* configure: Regenerate.
	* doc/xml/manual/configure.xml (--enable-libstdcxx-threads): Explain.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@184335 138bc75d-0d04-0410-961f-82ee72b054a4
---
 libstdc++-v3/configure.ac | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'libstdc++-v3/configure.ac')

diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index de5fe95b7e3..81b523f0342 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -165,9 +165,6 @@ GLIBCXX_CHECK_GETTIMEOFDAY
 # NB: The default is [no], because otherwise it requires linking.
 GLIBCXX_ENABLE_LIBSTDCXX_TIME([no])
 
-# For gthread support
-GLIBCXX_CHECK_GTHREADS
-
 AC_LC_MESSAGES
 
 # For hardware_concurrency
@@ -336,6 +333,9 @@ GLIBCXX_CONDITIONAL(GLIBCXX_LDBL_COMPAT, test $ac_ldbl_compat = yes)
 # This depends on GLIBCXX_ENABLE_SYMVERS and GLIBCXX_IS_NATIVE.
 GLIBCXX_CONFIGURE_TESTSUITE
 
+# For gthread support.  Depends on GLIBCXX_ENABLE_SYMVERS.
+GLIBCXX_CHECK_GTHREADS
+
 # Define documentation rules conditionally.
 
 # See if makeinfo has been installed and is modern enough
-- 
cgit v1.2.1