summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2002-11-06 11:38:35 +0000
committerAlan Modra <amodra@bigpond.net.au>2002-11-06 11:38:35 +0000
commit70f2850b2be6e2064b9b825da8cb7270f44e1bee (patch)
treeed84cf51236e1efdf07e1861817c20ac6d86fea9 /bfd/Makefile.am
parent994d6d5f1393ef7e5b50c89b85edd1c51f297a18 (diff)
downloadgdb-70f2850b2be6e2064b9b825da8cb7270f44e1bee.tar.gz
* Makefile.am: Remove entries for elf32-qnx.[ch].
* Makefile.in: Regenerate. * config.bfd: Change arm-nto to use bfd_elf32_{big|little}arm_vec, ppc-nto to use bfd_elf32_powerpc{le}_vec, sh-nto to use bfd_elf32_sh{l}_vec, and i386-nto to use bfd_elf32_i386_vec. * configure.in: Remove support for bfd_elf32_sh{l}qnx_vec, bfd_elf32_powerpc{le}qnx_vec, bfd_elf32_{big|little}armqnx_vec, and bfd_elf32_i386qnx_vec, and removed elf32-qnx.lo from other targets. bfd_elf32_sh{l}_vec, and i386-nto to use bfd_elf32_i386_vec. * configure: Regenerate. * elf32-qnx.c: Remove. * elf32-qnx.h: Remove. * elf.c: Remove calls to QNX specific set_nonloadable_filepos, is_contained_by_filepos, and copy_private_bfd_data_p. * elf32-i386.c: Remove QNX extended bfd support. * elf32-ppc.c: Remove QNX extended bfd support. * elf32-sh.c: Remove QNX extended bfd support. * elfarm-nabi.c: Remove QNX extended bfd support. * targets.c: Remove qnx vectors. * elfxx-target.h (elf_backend_set_nonloadable_filepos): Remove (elf_backend_is_contained_by_filepos): Remove. (elf_backend_copy_private_bfd_data_p): Remove. * po/SRC-POTFILES.in: Regenerate.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 151fff1d39d..59c2668be50 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -233,7 +233,6 @@ BFD32_BACKENDS = \
elf32-or32.lo \
elf32-pj.lo \
elf32-ppc.lo \
- elf32-qnx.lo \
elf32-s390.lo \
elf32-sh.lo \
elf32-sh64.lo \
@@ -388,7 +387,6 @@ BFD32_BACKENDS_CFILES = \
elf32-or32.c \
elf32-pj.c \
elf32-ppc.c \
- elf32-qnx.c \
elf32-sh64.c \
elf32-sh64-com.c \
elf32-s390.c \
@@ -561,7 +559,7 @@ CFILES = $(SOURCE_CFILES) $(BUILD_CFILES)
## This is a list of all .h files which are in the source tree.
SOURCE_HFILES = \
aout-target.h aoutf1.h aoutx.h coffcode.h coffswap.h ecoffswap.h \
- elf-bfd.h elf-hppa.h elf32-arm.h elf32-hppa.h elf32-qnx.h \
+ elf-bfd.h elf-hppa.h elf32-arm.h elf32-hppa.h \
elf64-hppa.h elfcode.h elfcore.h elflink.h \
freebsd.h genlink.h go32stub.h \
libaout.h libbfd.h libcoff.h libecoff.h libhppa.h libieee.h \
@@ -1099,7 +1097,7 @@ elfarm-oabi.lo: elfarm-oabi.c $(INCDIR)/elf/arm.h $(INCDIR)/elf/reloc-macros.h \
elfarm-nabi.lo: elfarm-nabi.c $(INCDIR)/elf/arm.h $(INCDIR)/elf/reloc-macros.h \
$(INCDIR)/filenames.h elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h \
- elf32-arm.h elf32-target.h elf32-qnx.h
+ elf32-arm.h elf32-target.h
elf32-avr.lo: elf32-avr.c $(INCDIR)/filenames.h elf-bfd.h \
$(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
$(INCDIR)/bfdlink.h $(INCDIR)/elf/avr.h $(INCDIR)/elf/reloc-macros.h \
@@ -1146,7 +1144,7 @@ elf32-i370.lo: elf32-i370.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf32-i386.lo: elf32-i386.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/elf/i386.h $(INCDIR)/elf/reloc-macros.h \
- elf32-target.h elf32-qnx.h
+ elf32-target.h
elf32-i860.lo: elf32-i860.c $(INCDIR)/filenames.h elf-bfd.h \
$(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
$(INCDIR)/bfdlink.h $(INCDIR)/elf/i860.h $(INCDIR)/elf/reloc-macros.h \
@@ -1217,10 +1215,7 @@ elf32-pj.lo: elf32-pj.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf32-ppc.lo: elf32-ppc.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/elf/ppc.h $(INCDIR)/elf/reloc-macros.h \
- elf32-target.h elf32-qnx.h
-elf32-qnx.lo: elf32-qnx.c $(INCDIR)/filenames.h elf-bfd.h \
- $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
- $(INCDIR)/bfdlink.h elf32-qnx.h
+ elf32-target.h
elf32-sh64.lo: elf32-sh64.c $(INCDIR)/filenames.h elf-bfd.h \
$(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
$(INCDIR)/bfdlink.h $(srcdir)/../opcodes/sh64-opc.h \
@@ -1237,7 +1232,7 @@ elf32-s390.lo: elf32-s390.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf32-sh.lo: elf32-sh.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/elf/sh.h $(INCDIR)/elf/reloc-macros.h \
- elf32-target.h elf32-qnx.h
+ elf32-target.h
elf32-sparc.lo: elf32-sparc.c $(INCDIR)/filenames.h \
$(INCDIR)/bfdlink.h elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/elf/sparc.h \