summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2000-07-01 01:41:09 +0000
committerAlan Modra <amodra@bigpond.net.au>2000-07-01 01:41:09 +0000
commit08477761a684a96c75e123a160fbbb5d235eecce (patch)
tree2703296c8cba7d316e9c77f3c6302a9b93036d05 /bfd/Makefile.am
parent8d9d90547b4388959c989c04f89bba82b8e8af77 (diff)
downloadgdb-08477761a684a96c75e123a160fbbb5d235eecce.tar.gz
Fix 2000-06-22. grep after running dep.sed
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 114a6266d61..6d408a3ec3f 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -576,11 +576,12 @@ install-data-local: $(BFD_H)
DEP: dep.sed $(CFILES) $(HFILES) bfd.h
rm -f DEP1
$(MAKE) MKDEP="$(MKDEP)" DEP1
- if grep ' /' DEP1 > /dev/null 2> /dev/null; then \
+ sed -f dep.sed < DEP1 > DEPA
+ echo '# IF YOU PUT ANYTHING HERE IT WILL GO AWAY' >> DEPA
+ if grep ' /' DEPA > /dev/null 2> /dev/null; then \
echo 'make DEP failed!'; exit 1; \
else \
- sed -f dep.sed < DEP1 > $@; \
- echo '# IF YOU PUT ANYTHING HERE IT WILL GO AWAY' >> $@; \
+ mv -f DEPA $@; \
fi
DEP1: $(CFILES)
@@ -670,7 +671,7 @@ stmp-lcoff-h: $(LIBCOFF_H_FILES)
MOSTLYCLEANFILES = elf32-target.h elf64-target.h ofiles stamp-ofiles \
targmatch.h
-CLEANFILES = bfd.h dep.sed stmp-bfd-h DEP DEP1 DEP2 libbfd.a stamp-lib \
+CLEANFILES = bfd.h dep.sed stmp-bfd-h DEP DEPA DEP1 DEP2 libbfd.a stamp-lib \
stmp-bin2-h stmp-lbfd-h stmp-lcoff-h
# We want to rerun configure if config.bfd or configure.host change.