summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorNathan Sidwell <nathan@codesourcery.com>2007-11-08 13:51:07 +0000
committerNathan Sidwell <nathan@codesourcery.com>2007-11-08 13:51:07 +0000
commit006aae21be3814cec84147f4139c24fd73dca147 (patch)
tree51c25b2e0dd7234c7898d5b299ac4b4406afa124 /bfd/Makefile.am
parent85d1670645588c2b7257e12e17eaf516c5ecb5b7 (diff)
downloadgdb-548510eda99bb8b15d32f4429ab50313a7d07e48.tar.gz
include/elf/gdb_6_7-branch
* vxworks.h: New. bfd/ * elf-vxworks.h (elf_vxworks_add_dynamic_entries): Declare. (elf_vxworks_finish_dynamic_entry): Declare. * elf-vxworks.c: Include elf/vxworks.h. (elf_vxworks_add_dynamic_entries): New. (elf_vxworks_finish_dynamic_entry): New. * Makefile.am (elf-vxworks.lo): Add dependency. * Makefile.in (elf-vxworks.lo): Add dependency. * elf32-i386.c (elf_i386_size_dynamic_sections, elf_i386_finish_dynamic_sections): Call elf_vxworks_add_dynamic_entries and elf_vxworks_finish_dynamic_entry. * elf32-ppc.c (ppc_elf_size_dynamic_sections, ppc_elf_finish_dynamic_sections): Likewise. * elfxx-sparc.c (_bfd_sparc_elf_size_dynamic_sections, sparc_finish_dyn): Likewise. * elf32-sh.c (sh_elf_size_dynamic_sections, sh_elf_finish_dynamic_sections): Likewise. * elfxx-mips.c (_bfd_mips_elf_size_dynamic_sections, _bfd_mips_elf_finish_dynamic_sections): Likewise. * elf32-arm.c (elf32_arm_size_dynamic_sections, elf32_arm_finish_dynamic_sections): Likewise. ld/ * ld-vxworks/tls-2.d: New. * ld-vxworks/tls-2.s: New.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 3d92daee53b..0ee4e3ea79f 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -1580,7 +1580,7 @@ elf-eh-frame.lo: elf-eh-frame.c $(INCDIR)/filenames.h \
elf-vxworks.lo: elf-vxworks.c $(INCDIR)/filenames.h \
$(INCDIR)/hashtab.h elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h \
- elf-vxworks.h
+ $(INCDIR)/elf/vxworks.h elf-vxworks.h
epoc-pe-arm.lo: epoc-pe-arm.c pe-arm.c $(INCDIR)/filenames.h \
coff-arm.c $(INCDIR)/hashtab.h $(INCDIR)/coff/arm.h \
$(INCDIR)/coff/external.h $(INCDIR)/coff/internal.h \