summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorThiemo Seufer <ths@networkno.de>2002-07-31 00:32:10 +0000
committerThiemo Seufer <ths@networkno.de>2002-07-31 00:32:10 +0000
commitc1f4a3f0a7fc0452d5cd41fce907b0767cd8612e (patch)
treefc4ebe935577c4a8cd05880b2b61ebd896a2f906 /bfd/Makefile.am
parent78f110661b8e50c2bd3ff05fe730f64a1164af89 (diff)
downloadgdb-c1f4a3f0a7fc0452d5cd41fce907b0767cd8612e.tar.gz
* Makefile.am: Add n32 ABI support.
* Makefile.in: Regenerate. * config.bfd: Add n32 vectors to mips64*-*-linux* targets. Treat 64 bit vectors for mips*-*-linux targets as optional. * configure.in: Add n32 ABI vectors. * configure: Regenerate. * elf32-mips.c (mips_elf32_object_p): Reject n32 ABI files. * elfn32-mips.c: New file, n32 ABI support. * targets.c: Add n32 ABI vectors.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 4ea4c93689a..92f5caa7223 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -482,6 +482,7 @@ BFD64_BACKENDS = \
elf64-hppa.lo \
elf64-ia64.lo \
elf64-gen.lo \
+ elfn32-mips.lo \
elf64-mips.lo \
elf64-mmix.lo \
elf64-sh64.lo \
@@ -506,6 +507,7 @@ BFD64_BACKENDS_CFILES = \
elf64-alpha.c \
elf64-hppa.c \
elf64-gen.c \
+ elfn32-mips.c \
elf64-mips.c \
elf64-mmix.c \
elf64-ppc.c \
@@ -1508,6 +1510,12 @@ elf64-hppa.lo: elf64-hppa.c $(INCDIR)/alloca-conf.h \
elf64-gen.lo: elf64-gen.c $(INCDIR)/filenames.h elf-bfd.h \
$(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
$(INCDIR)/bfdlink.h elf64-target.h
+elfn32-mips.lo: elfn32-mips.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
+ genlink.h elf-bfd.h elfxx-mips.h $(INCDIR)/elf/common.h \
+ $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/elf/mips.h \
+ $(INCDIR)/elf/reloc-macros.h $(INCDIR)/coff/sym.h \
+ $(INCDIR)/coff/symconst.h $(INCDIR)/coff/internal.h $(INCDIR)/coff/ecoff.h \
+ $(INCDIR)/coff/mips.h ecoffswap.h elf32-target.h
elf64-mips.lo: elf64-mips.c $(INCDIR)/filenames.h $(INCDIR)/aout/ar.h \
$(INCDIR)/bfdlink.h genlink.h elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h elfxx-mips.h \