summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2005-03-16 17:18:17 +0000
committerNick Clifton <nickc@redhat.com>2005-03-16 17:18:17 +0000
commit486317bd28d57b91236ffe86cbcc40b6b9c2a5e1 (patch)
treee4459e571988b1444b0d5c8ac4dcb7f1876f999b /bfd/configure.in
parent8f5a79c9f758fa059f330c84a1c034cb0df96c3a (diff)
downloadgdb-486317bd28d57b91236ffe86cbcc40b6b9c2a5e1.tar.gz
Rename switch to enable/disable -Werror to --enable-werror/--disable-werror
for compatibility with gcc.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index afcae656b1e..9eafb2c1092 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -53,21 +53,21 @@ esac],[want_mmap=false])dnl
build_warnings="-W -Wall -Wstrict-prototypes -Wmissing-prototypes"
-AC_ARG_ENABLE(error-on-warning,
- [ --enable-error-on-warning treat compile warnings as errors],
+AC_ARG_ENABLE(werror,
+ [ --enable-werror treat compile warnings as errors],
[case "${enableval}" in
yes | y) ERROR_ON_WARNING="yes" ;;
no | n) ERROR_ON_WARNING="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-error-on-warning) ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-werror) ;;
esac])
-# Enable -Werror by default, suppressing it only for --disable-error-on-warning
+# Enable -Werror by default, suppressing it only for --disable-werror
# or --disable-build-warnings.
if test "${ERROR_ON_WARNING}" != no
then
build_warnings="$build_warnings -Werror"
fi
-
+
AC_ARG_ENABLE(build-warnings,
[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
[case "${enableval}" in