summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2002-12-20 00:09:54 +0000
committerAlan Modra <amodra@bigpond.net.au>2002-12-20 00:09:54 +0000
commit664d146172d7a163e87170c47a2ecac80fda0074 (patch)
tree0a06c6130825f9f34d16bd661dfc60c3f5eca071 /bfd/configure.in
parentfcdfa0dba06175e623cf805a22caff9da32705dc (diff)
downloadgdb-664d146172d7a163e87170c47a2ecac80fda0074.tar.gz
* acinclude.m4 (AM_INSTALL_LIBBFD): Do not rely on "test -o".
* configure.in (build-warnings): Likewise. (Horrible hacks to build DLLs on Windows): Do not rely on "tail -1". * aclocal.m4: Regenerate. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index dc58f28bfa7..aa34e7da4b1 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -80,7 +80,7 @@ if test x"$silent" != x"yes" && test x"$build_warnings" != x""; then
echo "Setting warning flags = $build_warnings" 6>&1
fi])dnl
WARN_CFLAGS=""
-if test "x${build_warnings}" != x -a "x$GCC" = xyes ; then
+if test "x${build_warnings}" != x && test "x$GCC" = xyes ; then
WARN_CFLAGS="${build_warnings}"
fi
AC_SUBST(WARN_CFLAGS)
@@ -440,7 +440,7 @@ case "${host}" in
;;
*)
changequote(,)dnl
- x=`sed -n -e 's/^[ ]*PICFLAG[ ]*=[ ]*//p' < ../libiberty/Makefile | tail -1`
+ x=`sed -n -e 's/^[ ]*PICFLAG[ ]*=[ ]*//p' < ../libiberty/Makefile | sed -n '$p'`
changequote([,])dnl
if test -n "$x"; then
WIN32LIBADD="-L../libiberty/pic -liberty"