summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-04-09 12:17:43 +0000
committerAndrew Cagney <cagney@redhat.com>2000-04-09 12:17:43 +0000
commit397be7998e54fe196d174728fddf22ffbbd0e7a0 (patch)
treefb47e35dc461f8c338e85f6b5bb99c63d4e25a10 /bfd/configure.in
parent0ab691d921bb1acb9146b4b29eb947c6e7338aee (diff)
downloadgdb-397be7998e54fe196d174728fddf22ffbbd0e7a0.tar.gz
Remove ``-W -Wall'' from top-level Makefile/configure.
Add ``-W -Wall'' to sub-directories bfd, binutils, gas gprof, ld and opcodes by the addition of WARN_CFLAGS to Makefile.am and configury to set it. Add configure option --enable-build-warnings. Re-generate all and sundry using auto*-000227.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index 6371d688c86..3e3a689bcae 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -50,6 +50,27 @@ AC_ARG_WITH(mmap,
*) AC_MSG_ERROR(bad value ${withval} for BFD with-mmap option) ;;
esac],[want_mmap=false])dnl
+build_warnings="-W -Wall"
+AC_ARG_ENABLE(build-warnings,
+[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
+[case "${enableval}" in
+ yes) ;;
+ no) build_warnings="-w";;
+ ,*) t=`echo "${enableval}" | sed -e "s/,/ /g"`
+ build_warnings="${build_warnings} ${t}";;
+ *,) t=`echo "${enableval}" | sed -e "s/,/ /g"`
+ build_warnings="${t} ${build_warnings}";;
+ *) build_warnings=`echo "${enableval}" | sed -e "s/,/ /g"`;;
+esac
+if test x"$silent" != x"yes" && test x"$build_warnings" != x""; then
+ echo "Setting warning flags = $build_warnings" 6>&1
+fi])dnl
+WARN_CFLAGS=""
+if test "x${build_warnings}" != x -a "x$GCC" = xyes ; then
+ WARN_CFLAGS="${build_warnings}"
+fi
+AC_SUBST(WARN_CFLAGS)
+
AM_CONFIG_HEADER(config.h:config.in)
if test -z "$target" ; then