summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorH.J. Lu <hjl@lucon.org>2001-10-22 18:45:35 +0000
committerH.J. Lu <hjl@lucon.org>2001-10-22 18:45:35 +0000
commitf637c2895e0a3e93b373e33c1cc237eb4eba1a58 (patch)
treee92c5404d7a8646bd5787622393fd5e429aa5134 /bfd/configure.in
parentdbc4619a97b41a394536caa75463be426b8fd971 (diff)
downloadgdb-f637c2895e0a3e93b373e33c1cc237eb4eba1a58.tar.gz
2001-10-22 H.J. Lu <hjl@gnu.org>
* configure.in (WIN32LIBADD): Use -L../libiberty for mips*-*-linux*. * configure: Rebuild.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in24
1 files changed, 17 insertions, 7 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index 042cf18fb4a..b6602687912 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -413,13 +413,23 @@ case "${host}" in
*-*-linux*)
# We borrow WIN32LIBADD so that the shared libbfd won't depend on
# libiberty.a.
- PICFLAG=
- changequote(,)dnl
- eval `grep "^[ ]*PICFLAG[ ]*=" ../libiberty/Makefile | sed -e "s/[ ]*//g"`
- changequote([,])dnl
- if test -n "$PICFLAG"; then
- WIN32LIBADD="-L../libiberty/pic -liberty"
- fi
+ case "${host}" in
+ mips*-*-linux*)
+ # Linux/MIPS uses PIC by default.
+ if test "$enable_shared" = "yes"; then
+ WIN32LIBADD="-L../libiberty -liberty"
+ fi
+ ;;
+ *)
+ PICFLAG=
+ changequote(,)dnl
+ eval `grep "^[ ]*PICFLAG[ ]*=" ../libiberty/Makefile | sed -e "s/[ ]*//g"`
+ changequote([,])dnl
+ if test -n "$PICFLAG"; then
+ WIN32LIBADD="-L../libiberty/pic -liberty"
+ fi
+ ;;
+ esac
;;
esac
AC_SUBST(WIN32LDFLAGS)