summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorThiemo Seufer <ths@networkno.de>2001-12-05 22:46:21 +0000
committerThiemo Seufer <ths@networkno.de>2001-12-05 22:46:21 +0000
commit9d3f1c3a6777e560a4eec507fb98e8e726c2f346 (patch)
tree4cd7cf096771051684f544447f6a77ef69cf363e /bfd/configure.in
parentf653bbdfea8f69c49a108bff0812fc0b01f97a72 (diff)
downloadgdb-9d3f1c3a6777e560a4eec507fb98e8e726c2f346.tar.gz
* Makefile.am: split up BFD_LIBS like statements in BFD32_LIBS and
BFD64_LIBS, make the latter depending on the availability of BFD64. Add archive64.c source file. * archive64.c: New file implementing bfd_elf64_archive_slurp_armap and bfd_elf64_archive_write_armap, code from elf64-mips.c * archive.c (bfd_slurp_armap): Add ELF64 archive support. * config.bfd (mips*-*-irix6*): Allow with BFD64 only. (mips64*el-*-linux*): Likewise. (mips*el-*-linux*): Likewise. Reorder entries. * configure.in (bfd_libs): Define in dependency of BFD64 and AC_SUBST it. * elf64-mips.c (mips_elf64_slurp_armap): Remove, use bfd_elf64_archive_slurp_armap instead. (mips_elf64_write_armap): Remove, use bfd_elf64_archive_write_armap instead.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index b13b0d2f9a5..19242fd1204 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -761,6 +761,7 @@ fi # all_targets is true
case ${host64}-${target64}-${want64} in
*true*)
wordsize=64
+ bfd_libs='$(BFD64_LIBS) $(BFD32_LIBS)'
all_backends='$(BFD64_BACKENDS) $(BFD32_BACKENDS)'
if test -z "$GCC" && test "$BFD_HOST_64BIT_LONG" = "0" && test "$BFD_HOST_64_BIT_DEFINED" = "0"; then
AC_MSG_WARN([You have requested a 64 bit BFD configuration, but])
@@ -769,11 +770,13 @@ case ${host64}-${target64}-${want64} in
;;
false-false-false)
wordsize=32
+ bfd_libs='$(BFD32_LIBS)'
all_backends='$(BFD32_BACKENDS)'
;;
esac
AC_SUBST(wordsize)
+AC_SUBST(bfd_libs)
AC_SUBST(all_backends)
AC_SUBST(bfd_backends)
AC_SUBST(bfd_machines)