summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Elliston <bje@au.ibm.com>2007-08-13 01:32:36 +0000
committerBen Elliston <bje@au.ibm.com>2007-08-13 01:32:36 +0000
commita6ada392622995a5208670f6bf1302987b0b1989 (patch)
tree7482f211e359fb1b51437badd720dddb3c28febb /configure.ac
parent652d434fcd4b9f3fd49e6296115457beffbb7c5b (diff)
downloadgdb-a6ada392622995a5208670f6bf1302987b0b1989.tar.gz
* configure.ac (TOPLEVEL_CONFIGURE_ARGUMENTS, baseargs): Pass
--silent if $silent. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da88113f068..e9eea64e810 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,9 @@ do
# Add the quoted argument to the list.
TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS $ac_arg"
done
+if test "$silent" = yes; then
+ TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS --silent"
+fi
# Remove the initial space we just introduced and, as these will be
# expanded by make, quote '$'.
TOPLEVEL_CONFIGURE_ARGUMENTS=`echo "x$TOPLEVEL_CONFIGURE_ARGUMENTS" | sed -e 's/^x *//' -e 's,\\$,$$,g'`
@@ -2178,6 +2181,9 @@ EOF_SED
gcc_transform_name=`cat conftestsed.out`
rm -f conftestsed.out
baseargs="$baseargs --program-transform-name='${gcc_transform_name}'"
+if test "$silent" = yes; then
+ baseargs="$baseargs --silent"
+fi
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor