summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Daney <ddaney@avtrex.com>2007-09-12 17:51:22 +0000
committerDavid Daney <ddaney@avtrex.com>2007-09-12 17:51:22 +0000
commit5bf6827e474a9ef21fb4226b4d24b86c4252cef2 (patch)
tree8f5046a3361e37d320dc58362ccbcbd816819719 /configure.ac
parent82a310fba55ca196a813fbcc91d7af6a0a009745 (diff)
downloadgdb-5bf6827e474a9ef21fb4226b4d24b86c4252cef2.tar.gz
2007-09-12 David Daney <ddaney@avtrex.com>
* configure.ac: Remove mips64*-*-linux* noconfigdirs section, thus enabling libgcj. * configure: Regenerate. 2007-09-12 Richard Guenther <rguenther@suse.de> * configure.ac (--enable-stage1-checking): If neither --enable-checking nor --disable-checking is provided also turn on yes and types checking for stage1. * configure: Re-generate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fb8f7102a85..74238bf2de2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -795,9 +795,6 @@ case "${target}" in
mips*-*-bsd*)
noconfigdirs="$noconfigdirs gprof target-libgloss ${libgcj}"
;;
- mips64*-*-linux*)
- noconfigdirs="$noconfigdirs target-newlib target-libgloss ${libgcj}"
- ;;
mips*-*-linux*)
noconfigdirs="$noconfigdirs target-newlib target-libgloss"
;;
@@ -2646,10 +2643,10 @@ AC_ARG_ENABLE(stage1-checking,
[ --enable-stage1-checking@<:@=all@:>@ choose additional checking for stage1
of the compiler],
[stage1_checking=--enable-checking=${enable_stage1_checking}],
-[if test "x$enable_checking" = xno; then
+[if test "x$enable_checking" = xno || test "x$enable_checking" = x; then
stage1_checking=--enable-checking=yes,types
else
- stage1_checking=--enable-checking=types${enable_checking+,}$enable_checking
+ stage1_checking=--enable-checking=$enable_checking,types
fi])
AC_SUBST(stage1_checking)