summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHans-Peter Nilsson <hp@axis.com>2002-10-24 23:31:47 +0000
committerHans-Peter Nilsson <hp@axis.com>2002-10-24 23:31:47 +0000
commitfe170c20e6af342f4bc4b5d99b3db6d1553ec7d1 (patch)
tree7c2f08dfe7625467d4bc49e2fbcb48b38aba079a /configure.in
parent89d7930af1f1e5a083e97802cc39784e6dd3703d (diff)
downloadgdb-fe170c20e6af342f4bc4b5d99b3db6d1553ec7d1.tar.gz
* configure.in (i[3456]86-*-linux*): Add check to disable
${libgcj} for glibc1.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 87dd2c6dc41..6b714947a66 100644
--- a/configure.in
+++ b/configure.in
@@ -422,6 +422,13 @@ case "${target}" in
noconfigdirs="$noconfigdirs target-newlib target-libgloss"
;;
i[3456]86-*-linux*)
+ # The GCC port for glibc1 has no MD_FALLBACK_FRAME_STATE_FOR, so let's
+ # not build java stuff by default.
+ case "${target}" in
+ *-*-*libc1*)
+ noconfigdirs="$noconfigdirs ${libgcj}";;
+ esac
+
# This section makes it possible to build newlib natively on linux.
# If we are using a cross compiler then don't configure newlib.
if test x${is_cross_compiler} != xno ; then