summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH.J. Lu <hjl@lucon.org>2004-11-04 17:07:08 +0000
committerH.J. Lu <hjl@lucon.org>2004-11-04 17:07:08 +0000
commit7e663751cc63360d19ecdee64253f31fccb24fba (patch)
tree780dcd961812cb6c95c4837db20ca04e44dc85ed /configure.in
parentdd0ace3f2d92f6544122a840aad9f71f8befa911 (diff)
downloadgdb-7e663751cc63360d19ecdee64253f31fccb24fba.tar.gz
2004-11-04 H.J. Lu <hongjiu.lu@intel.com>
PR other/17783 * configure.in: Set up LD_LIBRARY_PATH by default for gcc. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index cd4ee039bcb..f0121a62b7f 100644
--- a/configure.in
+++ b/configure.in
@@ -1647,10 +1647,25 @@ case "${host}" in
;;
esac
+# If no --enable-shared nor --disable-shared is specified, we set up
+# LD_LIBRARY_PATH when we build for gcc.
+case $enable_shared in
+"")
+ if test -d ${srcdir}/gcc; then
+ set_lib_path=yes
+ else
+ set_lib_path=no
+ fi
+ ;;
+*)
+ set_lib_path=$enable_shared
+ ;;
+esac
+
# If --enable-shared was set, we must set LD_LIBRARY_PATH so that the
# binutils tools will find libbfd.so.
-case "${enable_shared}" in
- no | "") SET_LIB_PATH= ;;
+case "${set_lib_path}" in
+ no) SET_LIB_PATH= ;;
*) SET_LIB_PATH="\$(REALLY_SET_LIB_PATH)" ;;
esac
@@ -2328,8 +2343,8 @@ AC_SUBST(stage2_werror_flag)
# used.
SET_GCC_LIB_PATH=
if test -d ${srcdir}/gcc && test x${is_cross_compiler} = xno; then
- case "${enable_shared}" in
- no | "") ;;
+ case "${set_lib_path}" in
+ no) ;;
*)
eval "d=\$$RPATH_ENVVAR"
if test x"$d" != x; then