summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2004-10-23 20:30:02 +0000
committerDaniel Jacobowitz <dan@debian.org>2004-10-23 20:30:02 +0000
commit2915c035f57c7c71e87f91defccb8c3f8e3c0255 (patch)
tree04d6a9b3511cc8e3eed52e740c824bf528e0fc16 /configure.in
parent0c78ba4610e15c25b2c2b1dbd815a5c1fd71e8e1 (diff)
downloadgdb-2915c035f57c7c71e87f91defccb8c3f8e3c0255.tar.gz
* configure.in: Use an absolute path to install-sh.
* configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0ac43043abd..5670f9f1e02 100644
--- a/configure.in
+++ b/configure.in
@@ -80,10 +80,17 @@ AC_SUBST(TOPLEVEL_CONFIGURE_ARGUMENTS)
moveifchange=${srcdir}/move-if-change
+srcpwd=`cd ${srcdir} ; ${PWDCMD-pwd}`
+
+# We pass INSTALL explicitly to sub-makes. Make sure that it is not
+# a relative path.
+if test "$INSTALL" = "${srcdir}/install-sh -c"; then
+ INSTALL="${srcpwd}/install-sh -c"
+fi
+
# Set srcdir to "." if that's what it is.
# This is important for multilib support.
pwd=`${PWDCMD-pwd}`
-srcpwd=`cd ${srcdir} ; ${PWDCMD-pwd}`
if test "${pwd}" = "${srcpwd}" ; then
srcdir=.
fi