summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
committerMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
commit36ae0a56a7ce858a770eb45aa6d1be0688cbd966 (patch)
tree5a5c2940e23d1c7a0078f92e097cfd716198eae9 /configure.in
parentc09ec7e9fb47c7f119e656c1abe92c2a8c19c0cb (diff)
downloadgdb-36ae0a56a7ce858a770eb45aa6d1be0688cbd966.tar.gz
* config/mt-gnu (CXXFLAGS): Include SYSROOT_CFLAGS_FOR_TARGET.
* Makefile.tpl (SYSROOT_CFLAGS_FOR_TARGET): New variable. (CFLAGS_FOR_TARGET): Use it. (CXXFLAGS_FOR_TARGET): Likewise. * Makefile.in: Regenerated. * configure.in (--with-build-sysroot): New option. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d7c006c129a..f5877a708a4 100644
--- a/configure.in
+++ b/configure.in
@@ -1405,6 +1405,15 @@ esac
copy_dirs=
+AC_ARG_WITH([build-sysroot],
+ [ --with-build-sysroot=sysroot
+ use sysroot as the system root during the build],
+ [if test x"$withval" != x ; then
+ SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
+ fi],
+ [SYSROOT_CFLAGS_FOR_TARGET=])
+AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then