summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorMark Kettenis <kettenis@gnu.org>2005-01-21 13:14:02 +0000
committerMark Kettenis <kettenis@gnu.org>2005-01-21 13:14:02 +0000
commit6dc01d7c3a2358b28e8a85b45e571fc02e72c5bb (patch)
tree0344bfa45baf1bd1d1882cc86ab8438a5f6a5c3c /gdb/configure.ac
parentb19aa7add36e1771981de4302657276a705405ca (diff)
downloadgdb-6dc01d7c3a2358b28e8a85b45e571fc02e72c5bb.tar.gz
* configure.ac: Use AC_CHECK_DECLS instead of gcc_AC_CHECK_DECLS
and BFD_NEED_DECLARATION. Don't check if a declaration of strdup is necessary. * configure, config.in: Regenerate. * utils.c: Adjust for usage of AC_CHECK_DECLS instead of BFD_NEED_DECLARATION. Never provide a prototype for caninicalize_file_name. * gdb_string.h: Adjust for usage of AC_CHECK_DECLS instead of BFD_NEED_DECLARATION.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 82c8bbe8176..7243cbd0925 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -424,7 +424,9 @@ AC_CHECK_HEADERS(ctype.h time.h)
# Checks for declarations. #
# ------------------------- #
-gcc_AC_CHECK_DECLS(getopt)
+AC_CHECK_DECLS([free, malloc, realloc])
+AC_CHECK_DECLS([strerror, strstr])
+AC_CHECK_DECLS(getopt)
# ----------------------- #
# Checks for structures. #
@@ -477,7 +479,7 @@ gdb_ptrace_headers='
#endif
'
# There is no point in checking if we don't have a prototype.
-gcc_AC_CHECK_DECLS(ptrace, , [
+AC_CHECK_DECLS(ptrace, [], [
: ${gdb_cv_func_ptrace_ret='int'}
: ${gdb_cv_func_ptrace_args='int,int,long,long'}
], $gdb_ptrace_headers)
@@ -694,14 +696,6 @@ if test $gdb_cv_have_uintptr_t = yes; then
AC_DEFINE(HAVE_UINTPTR_T, 1, [Define if <stdint.h> provides the uintptr_t type.])
fi
-BFD_NEED_DECLARATION(malloc)
-BFD_NEED_DECLARATION(realloc)
-BFD_NEED_DECLARATION(free)
-BFD_NEED_DECLARATION(strerror)
-BFD_NEED_DECLARATION(strdup)
-BFD_NEED_DECLARATION(strstr)
-BFD_NEED_DECLARATION(canonicalize_file_name)
-
# If we are configured native on GNU/Linux, work around problems with
# sys/procfs.h
# Also detect which type of /proc is in use, such as for Unixware or Solaris.