summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2007-01-09 14:58:57 +0000
committerDaniel Jacobowitz <dan@debian.org>2007-01-09 14:58:57 +0000
commit6d45f1ea3c7e482feeaabcd43cb03099873d2f9d (patch)
tree2e68f6afdf9d71ec0e4998a9cf5a5ecad9b518e5 /gdb/configure.ac
parent1c7033a53c52393de14fce6d2edd353b69702342 (diff)
downloadgdb-6d45f1ea3c7e482feeaabcd43cb03099873d2f9d.tar.gz
* configure.ac: Check for XML_StopParser.
* xml-support.c (gdb_xml_body_text): Check for an error. (gdb_xml_start_element_wrapper): Conditionalize call to XML_StopParser. (gdb_xml_end_element_wrapper): Likewise. * config.in, configure: Regenerated.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 563782e3db6..3a55c515735 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -325,6 +325,11 @@ AC_LIB_HAVE_LINKFLAGS([expat], [], [#include "expat.h"],
[XML_Parser p = XML_ParserCreate (0);])
if test "$HAVE_LIBEXPAT" != yes; then
AC_MSG_WARN([expat is missing or unusable; some features may be disabled.])
+else
+ save_LIBS=$LIBS
+ LIBS="$LIBS $LIBEXPAT"
+ AC_CHECK_FUNCS(XML_StopParser)
+ LIBS=$save_LIBS
fi
# ------------------------- #