summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2008-04-14 18:04:00 +0000
committerDaniel Jacobowitz <dan@debian.org>2008-04-14 18:04:00 +0000
commit9c9eabcbe003d635d12d43b5a926d7c01c2f5928 (patch)
tree13168d59d6bfe4559cab11da3bb1c7812cd5772f /gdb/configure.ac
parentcdfb2db5bd372110d0573436166b2cb0249bf597 (diff)
downloadgdb-9c9eabcbe003d635d12d43b5a926d7c01c2f5928.tar.gz
* Makefile.in (LIBGNU, INCGNU): Define.
(INTERNAL_CFLAGS_BASE): Add INCGNU. (INTERNAL_LIBS, CLIBS, CDEPS): Add LIBGNU. (CLEANDIRS): New. ($(LIBGNU), all-lib): New rules. (clean, distclean, do-maintainer-clean): Use CLEANDIRS. * configure.ac: Use gl_EARLY, gl_INIT, and AM_INIT_AUTOMAKE. Simplify AC_CONFIG_AUX_DIR. Generate gnulib/Makefile. * gnulib: New directory, from gnulib-tool. * configure, aclocal.m4: Regenerated. * Makefile.in (LIBOBJS): New. (OBS): Use LIBOBJS. (memmem.o): New rule. * configure.ac: Use AC_CONFIG_LIBOBJ_DIR and check for memmem. * configure: Regenerated.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index fcc35136a8e..43aa2dd0928 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1,6 +1,6 @@
dnl Autoconf configure script for GDB, the GNU debugger.
dnl Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004,
-dnl 2005, 2006
+dnl 2005, 2006, 2007, 2008
dnl Free Software Foundation, Inc.
dnl
dnl This file is part of GDB.
@@ -29,9 +29,10 @@ AC_PROG_CC
AC_GNU_SOURCE
AC_AIX
AC_ISC_POSIX
+gl_EARLY
AM_PROG_CC_STDC
-AC_CONFIG_AUX_DIR(`cd $srcdir;pwd`/..)
+AC_CONFIG_AUX_DIR(..)
AC_CANONICAL_SYSTEM
dnl List of object files and targets accumulated by configure.
@@ -59,10 +60,16 @@ if test x"$USE_NLS" = xyes; then
CONFIG_UNINSTALL="$CONFIG_UNINSTALL uninstall-po"
fi
+gl_INIT
+
PACKAGE=gdb
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Name of this package. ])
AC_SUBST(PACKAGE)
+# GDB does not use automake, but gnulib does. This line lets us
+# generate its Makefile.in.
+AM_INIT_AUTOMAKE(gdb, UNUSED-VERSION, [no-define])
+
debugdir=${libdir}/debug
AC_ARG_WITH(separate-debug-dir,
@@ -207,8 +214,6 @@ if test "x$targ_defvec" != x; then
[Define to BFD's default target vector. ])
fi
-AC_ARG_PROGRAM
-
# The CLI cannot be disabled yet, but may be in the future.
# Enable CLI.
@@ -1721,7 +1726,7 @@ AC_DEFINE(GDB_DEFAULT_HOST_CHARSET, "ISO-8859-1",
AM_ICONV
-AC_OUTPUT(Makefile .gdbinit:gdbinit.in,
+AC_OUTPUT(Makefile .gdbinit:gdbinit.in gnulib/Makefile,
[
dnl Autoconf doesn't provide a mechanism for modifying definitions
dnl provided by makefile fragments.