summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorRichard Sandiford <rsandifo@nildram.co.uk>2007-05-16 07:24:08 +0000
committerRichard Sandiford <rsandifo@nildram.co.uk>2007-05-16 07:24:08 +0000
commiteec3c953abab27e72cef9a814272b586a38d8403 (patch)
tree1470313eb3a45fdb50e5ea25be3cada2613b85ef /gdb/configure.ac
parent540618f2001c39830b2305b2ef0c9ca8ecfcb7d7 (diff)
downloadgdb-eec3c953abab27e72cef9a814272b586a38d8403.tar.gz
gdb/
* configure.ac: Allow sysroots to be relocated under $prefix as well as $exec_prefix. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 6db1a189e9f..3a579fda724 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1121,17 +1121,20 @@ AC_ARG_WITH(sysroot,
TARGET_SYSTEM_ROOT_DEFINE='-DTARGET_SYSTEM_ROOT=\"$(TARGET_SYSTEM_ROOT)\"'
+ if test "x$prefix" = xNONE; then
+ test_prefix=/usr/local
+ else
+ test_prefix=$prefix
+ fi
if test "x$exec_prefix" = xNONE || test "x$exec_prefix" = 'x${prefix}'; then
- if test "x$prefix" = xNONE; then
- test_prefix=/usr/local
- else
- test_prefix=$prefix
- fi
+ test_exec_prefix=$test_prefix
else
- test_prefix=$exec_prefix
+ test_exec_prefix=$exec_prefix
fi
case ${TARGET_SYSTEM_ROOT} in
"${test_prefix}"|"${test_prefix}/"*|\
+ "${test_exec_prefix}"|"${test_exec_prefix}/"*|\
+ '${prefix}'|'${prefix}/'*|\
'${exec_prefix}'|'${exec_prefix}/'*)
t="$TARGET_SYSTEM_ROOT_DEFINE -DTARGET_SYSTEM_ROOT_RELOCATABLE"
TARGET_SYSTEM_ROOT_DEFINE="$t"