summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2004-02-08 04:25:07 +0000
committerAndrew Cagney <cagney@redhat.com>2004-02-08 04:25:07 +0000
commit3811ac2ea81ce32f20b55fd9c69c49643ca6810b (patch)
tree9d53c85449e95ec494e5cb57247c37f5350d5afe /gdb/configure.in
parente736eea32e06282e0f11bb4b048eccad08415e63 (diff)
downloadgdb-3811ac2ea81ce32f20b55fd9c69c49643ca6810b.tar.gz
2004-02-07 Andrew Cagney <cagney@redhat.com>
* configure.in (CONFIG_INITS, CONFIG_LIB_OBS): Delete. * configure: Re-generate (with correct autoconf). * Makefile.in (INIT_FILES): Replace CONFIG_INITS with CONFIG_SRCS. (CONFIG_LIB_OBS, CONFIG_INITS): Delete. (COMMON_OBS): Add "main.o" and "annotate.o". (ANNOTATE_OBS): Delete. (OBS): Remove ANNOTATE_OBS. (DEPFILES): Replace CONFIG_LIB_OBS with CONFIG_LIB_OBS, remove CONFIG_INITS. (gdb$(EXEEXT), insight$(EXEEXT)): Do not depend on, or link against CONFIG_OBS and "main.o". (SUBDIR_CLI_INITS, SUBDIR_MI_INITS): Delete. (SUBDIR_TUI_INITS, SUBDIR_GDBTK_INITS): Delete.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in8
1 files changed, 0 insertions, 8 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 46df6299b35..b695140d867 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -60,10 +60,8 @@ AC_DEFINE_DIR(DEBUGDIR, debugdir,
dnl List of object files added by configure.
CONFIG_OBS=
-CONFIG_LIB_OBS=
CONFIG_DEPS=
CONFIG_SRCS=
-CONFIG_INITS=
ENABLE_CFLAGS=
CONFIG_ALL=
CONFIG_CLEAN=
@@ -114,7 +112,6 @@ if test x"$enable_gdbcli" = xyes; then
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_CLI_OBS)"
CONFIG_DEPS="$CONFIG_DEPS \$(SUBDIR_CLI_DEPS)"
CONFIG_SRCS="$CONFIG_SRCS \$(SUBDIR_CLI_SRCS)"
- CONFIG_INITS="$CONFIG_INITS \$(SUBDIR_CLI_INITS)"
ENABLE_CFLAGS="$ENABLE_CFLAGS \$(SUBDIR_CLI_CFLAGS)"
CONFIG_ALL="$CONFIG_ALL \$(SUBDIR_CLI_ALL)"
CONFIG_CLEAN="$CONFIG_CLEAN \$(SUBDIR_CLI_CLEAN)"
@@ -138,7 +135,6 @@ if test x"$enable_gdbmi" = xyes; then
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_MI_OBS)"
CONFIG_DEPS="$CONFIG_DEPS \$(SUBDIR_MI_DEPS)"
CONFIG_SRCS="$CONFIG_SRCS \$(SUBDIR_MI_SRCS)"
- CONFIG_INITS="$CONFIG_INITS \$(SUBDIR_MI_INITS)"
ENABLE_CFLAGS="$ENABLE_CFLAGS \$(SUBDIR_MI_CFLAGS)"
CONFIG_ALL="$CONFIG_ALL \$(SUBDIR_MI_ALL)"
CONFIG_CLEAN="$CONFIG_CLEAN \$(SUBDIR_MI_CLEAN)"
@@ -161,7 +157,6 @@ if test x"$enable_tui" = xyes; then
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_TUI_OBS)"
CONFIG_DEPS="$CONFIG_DEPS \$(SUBDIR_TUI_DEPS)"
CONFIG_SRCS="$CONFIG_SRCS \$(SUBDIR_TUI_SRCS)"
- CONFIG_INITS="$CONFIG_INITS \$(SUBDIR_TUI_INITS)"
ENABLE_CFLAGS="$ENABLE_CFLAGS \$(SUBDIR_TUI_CFLAGS)"
CONFIG_ALL="$CONFIG_ALL \$(SUBDIR_TUI_ALL)"
CONFIG_CLEAN="$CONFIG_CLEAN \$(SUBDIR_TUI_CLEAN)"
@@ -1214,7 +1209,6 @@ if test "${enable_gdbtk}" = "yes"; then
CONFIG_OBS="${CONFIG_OBS} \$(SUBDIR_GDBTK_OBS)"
CONFIG_DEPS="${CONFIG_DEPS} \$(SUBDIR_GDBTK_DEPS)"
CONFIG_SRCS="${CONFIG_SRCS} \$(SUBDIR_GDBTK_SRCS)"
- CONFIG_INITS="${CONFIG_INITS} \$(SUBDIR_GDBTK_INITS)"
CONFIG_ALL="${CONFIG_ALL} \$(SUBDIR_GDBTK_ALL)"
CONFIG_CLEAN="${CONFIG_CLEAN} \$(SUBDIR_GDBTK_CLEAN)"
CONFIG_INSTALL="${CONFIG_INSTALL} \$(SUBDIR_GDBTK_INSTALL)"
@@ -1284,10 +1278,8 @@ AC_SUBST(ENABLE_CFLAGS)
AC_SUBST(PROFILE_CFLAGS)
AC_SUBST(CONFIG_OBS)
-AC_SUBST(CONFIG_LIB_OBS)
AC_SUBST(CONFIG_DEPS)
AC_SUBST(CONFIG_SRCS)
-AC_SUBST(CONFIG_INITS)
AC_SUBST(CONFIG_ALL)
AC_SUBST(CONFIG_CLEAN)
AC_SUBST(CONFIG_INSTALL)