summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2002-01-20 18:19:30 +0000
committerAndrew Cagney <cagney@redhat.com>2002-01-20 18:19:30 +0000
commit3d891f56c452ff2c5e704e83280decde41c6d560 (patch)
treeb3e227e1cb876dba59996b07733c4ad876b2fa76 /gdb/configure.in
parent419c88be1db89b32ae478e916c09dd3238f2aec2 (diff)
downloadgdb-3d891f56c452ff2c5e704e83280decde41c6d560.tar.gz
Remove assumption that there is a host.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 6eef43cf884..25d7068016a 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -1203,7 +1203,14 @@ AC_SUBST(target_subdir)
frags=
host_makefile_frag=${srcdir}/config/${gdb_host_cpu}/${gdb_host}.mh
if test ! -f ${host_makefile_frag}; then
-AC_MSG_ERROR("*** Gdb does not support host ${host}")
+ # When building a native debuger the .mh file containing things
+ # like NATDEPFILES is needed. Cross debuggers don't need .mh
+ # since it no longer contains anything useful.
+ if test "${target}" = "${host}"; then
+ AC_MSG_ERROR("*** Gdb does not support native target ${host}")
+ else
+ host_makefile_frag=/dev/null
+ fi
fi
frags="$frags $host_makefile_frag"