summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-06-11 01:39:08 +0000
committerAndrew Cagney <cagney@redhat.com>2000-06-11 01:39:08 +0000
commitc9629e520586c5c04b73204b9af17b46b8e9a92e (patch)
tree4f3c9ac75cb8f2018a098b478e1d8dc904c85714 /gdb/configure.in
parentba807cb0f333532256ccd25bc3a6eecb8b0259c7 (diff)
downloadgdb-c9629e520586c5c04b73204b9af17b46b8e9a92e.tar.gz
Trim targ_arches to just the first.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index f512b82ba25..958ff9c8a53 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -80,6 +80,10 @@ dnl use BFD to determine the default architecture and byte order
dnl (bfd_vec->byteorder provides the latter).
targ=${target}
. ${srcdir}/../bfd/config.bfd
+
+dnl We only want the first arch, if there is more than one.
+targ_archs=`echo ${targ_archs} | sed -e 's/ .*//;'`
+
if test x"${targ_archs}" != x ; then
AC_DEFINE_UNQUOTED(DEFAULT_BFD_ARCH, ${targ_archs})
fi