summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2002-02-14 05:31:46 +0000
committerDaniel Jacobowitz <dan@debian.org>2002-02-14 05:31:46 +0000
commitbeec5b74f24e0616e3527ac687b264d52028ad9d (patch)
tree71ee2c169437191a71fb902251c41f2148d30c79 /gdb/configure.in
parent249c6bc2819a5f5006783fc15d09f12e55439193 (diff)
downloadgdb-beec5b74f24e0616e3527ac687b264d52028ad9d.tar.gz
2002-02-14 Daniel Jacobowitz <drow@mvista.com>
* configure.tgt: Configure gdbserver only for known working targets. Set ${build_gdbserver} instead of modifying ${configdirs}. * configure.in: Check ${build_gdbserver}. Put gdbserver/ into SUBDIRS if it is configured. Update comment for ${nativefile}. * configure: Regenerated.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in21
1 files changed, 14 insertions, 7 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 25d7068016a..672f2600579 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -1237,16 +1237,12 @@ GDB_MULTI_ARCH=`sed -n '
s/GDB_MULTI_ARCH[ ]*=[ ]*\([^ ]*\)[ ]*/\1/p
' ${target_makefile_frag}`
-# these really aren't orthogonal true/false values of the same condition,
-# but shells are slow enough that I like to reuse the test conditions
-# whenever possible
if test "${target}" = "${host}"; then
+# We pick this up from the host configuration file (.mh) because we
+# do not have a native configuration Makefile fragment.
nativefile=`sed -n '
s/NAT_FILE[ ]*=[ ]*\([^ ]*\)/\1/p
' ${host_makefile_frag}`
-# else
-# GDBserver is only useful in a "native" environment
-# configdirs=`echo $configdirs | sed 's/gdbserver//'`
fi
changequote([,])
@@ -1277,12 +1273,23 @@ case "${GDB_MULTI_ARCH}" in
*) AC_MSG_ERROR("GDB: Unknown GDB_MULTI_ARCH value ${GDB_MULTI_ARCH}");;
esac
-
SUBDIRS="doc testsuite nlm"
if test "${enable_multi_ice}" = "yes"; then
SUBDIRS="${SUBDIRS} multi-ice"
fi
+# ``gdbserver'' can only be built in a native configuration.
+if test x"${target}" = x"${host}"; then
+ AC_MSG_CHECKING(whether gdbserver is supported on this host)
+ if test x"${build_gdbserver}" = xyes ; then
+ configdirs="${configdirs} gdbserver"
+ SUBDIRS="${SUBDIRS} gdbserver"
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+fi
+
AC_SUBST(SUBDIRS)
# If hostfile (XM_FILE) and/or targetfile (TM_FILE) and/or nativefile