summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorJoel Brobecker <brobecker@gnat.com>2004-02-25 20:09:46 +0000
committerJoel Brobecker <brobecker@gnat.com>2004-02-25 20:09:46 +0000
commit74bd356452248d8fd010380ee4eaef7070e7964d (patch)
tree2bee8f07fed7c3031f0a0e95645ed9e3c43db1b0 /gdb/configure.in
parent9071c6a390f1a2395f01d9bbdaa5fbfdc2f87fc2 (diff)
downloadgdb-74bd356452248d8fd010380ee4eaef7070e7964d.tar.gz
* configure.in: Make sure that the wborder function is available.
Otherwise, search for it in the cur_colr library. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 2d912fbc1df..e8df001521c 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -146,6 +146,16 @@ fi
AC_SEARCH_LIBS(initscr, [ncurses Hcurses curses pdcurses], [],
[AC_MSG_WARN([no curses library found])])
+# Check whether the wborder function is provided by the curses
+# library detected above. In certain implementations such as
+# the HP/UX Hcurses for instance, this function is provided by an
+# additional library. So if we did not find this function inside
+# the curses library, try some alternate libraries we know might
+# provide it.
+AC_CHECK_FUNC(wborder, [wborder_available=yes],
+ [AC_SEARCH_LIBS(wborder, [cur_colr], [wborder_available=yes],
+ [AC_MSG_WARN([no wborder function found])])])
+
# Enable TUI.
AC_ARG_ENABLE(tui,
[ --enable-tui enable full-screen terminal user interface (TUI)],
@@ -157,7 +167,7 @@ AC_ARG_ENABLE(tui,
esac],enable_tui=yes)
if test x"$enable_tui" = xyes; then
if test -d $srcdir/tui; then
- if test "$ac_cv_search_initscr" != no; then
+ if test "$ac_cv_search_initscr" != no -a "$wborder_available" = "yes"; then
CONFIG_OBS="$CONFIG_OBS \$(SUBDIR_TUI_OBS)"
CONFIG_DEPS="$CONFIG_DEPS \$(SUBDIR_TUI_DEPS)"
CONFIG_SRCS="$CONFIG_SRCS \$(SUBDIR_TUI_SRCS)"