summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2003-12-30 06:52:09 +0000
committerEli Zaretskii <eliz@gnu.org>2003-12-30 06:52:09 +0000
commit0fb99254cb1ed72d00a00e16288969c571389f5d (patch)
treef385fffb5cd9957a4e09d5798a13d267dbdb963a /gdb/configure.in
parent3cbf68ded34c222edc122f2f0c4fd42f2bff4af1 (diff)
downloadgdb-0fb99254cb1ed72d00a00e16288969c571389f5d.tar.gz
* remote-fileio.c (remote_fileio_to_fio_stat)
(remote_fileio_func_fstat) [HAVE_STRUCT_STAT_ST_BLOCKS]: Support systems that don't have `st_blocks' member in `struct stat'. * configure.in (HAVE_STRUCT_STAT_ST_BLOCKS): Ditto.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index d27470cb6c8..f0f65c22c58 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -383,6 +383,12 @@ AC_CHECK_HEADERS(curses.h ncurses.h term.h)
# unconditionally, so what's the point in checking these?
AC_CHECK_HEADERS(ctype.h time.h)
+# remote-fileio.c needs st_blocks
+AC_CHECK_MEMBER(struct stat.st_blocks,
+ [AC_DEFINE(HAVE_STRUCT_STAT_ST_BLOCKS, 1,
+ [Define if struct stat has st_blocks member.])],
+ [#include <sys/stat.h>])
+
# ------------------------- #
# Checks for declarations. #
# ------------------------- #