summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorMark Kettenis <kettenis@gnu.org>2001-08-27 22:39:56 +0000
committerMark Kettenis <kettenis@gnu.org>2001-08-27 22:39:56 +0000
commitdfbd73589ebef873cfc401cba17c7792b0aa26de (patch)
tree40dde8dcb8780ff0cade998857c37c23361097fa /gdb/configure.in
parent039a0a12de76b9aa7c1a99de786798b62374a047 (diff)
downloadgdb-dfbd73589ebef873cfc401cba17c7792b0aa26de.tar.gz
* event-top.c (async_stop_sig) [HAVE_SIGPROCMASK]: Some
gratuitious whitespace changes. [!HAVE_SIGPROCMASK]: Call sigsetmask if HAVE_SIGSETMASK is defined. * top.c: Remove redundant logic to define HAVE_SIGSETMASK. (sigsetmask) Don't define macro. (stop_sig) [HAVE_SIGPROCMASK]: Add bit of code snatched from async_stop_sig from event-top.c. [!HAVE_SIGPROCMASK]: Call sigsetmask if HAVE_SIGSETMASK is defined. * configure.in (AC_CHECK_FUNCS): Put functions in alphabetical order. Add sigsetmask. (AC_FUNC_VFORK, AC_FUNC_ALLOCA): Reorder such that they're in alphabetical order. * config/xm-aix4.h, config/alpha/xm-alphalinux.h, config/i386/xm-cygwin.h, config/rs6000/xm-rs6000.h (HAVE_SIGSETMASK): Remove. * aclocal.m4, config.in, configure
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 6c30972ad63..bec40e037a6 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -131,9 +131,10 @@ AC_HEADER_STAT
AC_C_CONST
-AC_CHECK_FUNCS(setpgid setpgrp sbrk sigaction isascii bzero bcopy btowc poll sigprocmask)
-AC_FUNC_VFORK
+AC_CHECK_FUNCS(bcopy btowc bzero isascii poll sbrk setpgid setpgrp \
+ sigaction sigprocmask sigsetmask)
AC_FUNC_ALLOCA
+AC_FUNC_VFORK
dnl AC_FUNC_SETPGRP does not work when cross compiling
dnl Instead, assume we will have a prototype for setpgrp if cross compiling.
if test "$cross_compiling" = no; then