summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorDJ Delorie <dj@delorie.com>2000-09-05 18:44:54 +0000
committerDJ Delorie <dj@delorie.com>2000-09-05 18:44:54 +0000
commita012727cc43bddbfd2257838411bd313c24466d7 (patch)
tree090302fb8cbdff7e54afcb0e396e8ab889ce8e19 /libiberty/configure.in
parentcd8aa442074e120118d0a33c33acfd83284c1c66 (diff)
downloadgdb-a012727cc43bddbfd2257838411bd313c24466d7.tar.gz
* configure.in (Cygwin): special case cygwin only when we're
building cygwin, not when we're hosting cygwin.
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index 041a43dc3c7..adfbd5ff670 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -280,10 +280,15 @@ if test -z "${setobjs}"; then
# provides from our shell variables, so that they appear to be
# missing.
- funcs="`echo $funcs | sed -e 's/random//'`"
- LIBOBJS="$LIBOBJS random.o"
- vars="`echo $vars | sed -e 's/sys_siglist//'`"
- checkfuncs="`echo $checkfuncs | sed -e 's/strsignal//' -e 's/psignal//'`"
+ # DJ - only if we're *building* cygwin, not just building *with* cygwin
+
+ if test -n "${with_target_subdir}"
+ then
+ funcs="`echo $funcs | sed -e 's/random//'`"
+ LIBOBJS="$LIBOBJS random.o"
+ vars="`echo $vars | sed -e 's/sys_siglist//'`"
+ checkfuncs="`echo $checkfuncs | sed -e 's/strsignal//' -e 's/psignal//'`"
+ fi
;;
*-*-mingw32*)