summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorDJ Delorie <dj@delorie.com>2002-05-08 14:22:36 +0000
committerDJ Delorie <dj@delorie.com>2002-05-08 14:22:36 +0000
commit7c6563d0ad71444d52acdc8991a6e22dc351094a (patch)
tree8d76f9640e315ed0b5b73cf26a364409fab35f4b /libiberty/configure.in
parenta8d24419eff87249d6e9c63dea3657ca2df97a94 (diff)
downloadgdb-7c6563d0ad71444d52acdc8991a6e22dc351094a.tar.gz
merge from gcc
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index f3ec32ae3c4..f6d92bcb03e 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -3,6 +3,12 @@ dnl Process this file with autoconf to produce a configure script
AC_PREREQ(2.13)
AC_INIT(pexecute.c)
+# This works around the fact that libtool configuration may change LD
+# for this particular configuration, but some shells, instead of
+# keeping the changes in LD private, export them just because LD is
+# exported. We don't use libtool yet, but some day we might, so...
+ORIGINAL_LD_FOR_MULTILIBS=$LD
+
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
[ --with-target-subdir=SUBDIR Configuring in a subdirectory for target])
@@ -427,6 +433,7 @@ if test -n "$CONFIG_FILES"; then
if test -n "${with_build_subdir}" || test -n "${with_target_subdir}"; then
# FIXME: We shouldn't need to set ac_file
ac_file=Makefile
+ LD="${ORIGINAL_LD_FOR_MULTILIBS}"
. ${libiberty_topdir}/config-ml.in
fi
fi],