summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorJim Blandy <jimb@codesourcery.com>2005-02-08 04:52:24 +0000
committerJim Blandy <jimb@codesourcery.com>2005-02-08 04:52:24 +0000
commit4515748a5c590cfdb52237c652ad34e8bb59df61 (patch)
tree80cf35f54d5ad1c98f7a88ebba5dbf52a4fec89a /opcodes/Makefile.am
parentfa33692eea53c544b4c0f8a83cd6adae7f864b71 (diff)
downloadgdb-4515748a5c590cfdb52237c652ad34e8bb59df61.tar.gz
cgen/ChangeLog:
2005-02-07 Jim Blandy <jimb@redhat.com> * cgen-opc.scm: Don't load fixup.scm here. (See corresponding changes in the opcodes directory.) opcodes/ChangeLog: 2005-02-07 Jim Blandy <jimb@redhat.com> * Makefile.am (CGEN): Load guile.scm before calling the main application script. * Makefile.in: Regenerated. * cgen.sh: Be prepared for the 'cgen' argument to contain spaces. Simply pass the cgen-opc.scm path to ${cgen} as its first argument; ${cgen} itself now contains the '-s', or whatever is appropriate for the Scheme being used.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 36df7d951af..2176b43d5b0 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -357,7 +357,7 @@ CLEANFILES = \
CGENDIR = @cgendir@
CPUDIR = $(CGENDIR)/cpu
-CGEN = `if test -f ../guile/libguile/guile ; then echo ../guile/libguile/guile; else echo guile ; fi`
+CGEN = "`if test -f ../guile/libguile/guile ; then echo ../guile/libguile/guile; else echo guile ; fi` -l ${cgendir}/guile.scm -s"
CGENFLAGS = -v
CGENDEPS = \