summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2007-10-04 14:06:40 +0000
committerNick Clifton <nickc@redhat.com>2007-10-04 14:06:40 +0000
commit8cf713f89442a3575daadbb606decb670f95829f (patch)
tree1193e71a3f38f7c613343fd3382ac43b8fe3469e /opcodes/Makefile.am
parent268448a19e8c2942f239b16bf69a7bcc4978cbc0 (diff)
downloadgdb-8cf713f89442a3575daadbb606decb670f95829f.tar.gz
* configure.in (WIN32LDFLAGS): Rename to SHARED_LDFLAGS.
(WIN32LIBADD): Rename to SHARED_LIBADD (SHARED_DEPENDENCIES): New exported variable. (enable_shared): Add dependency upon libbfd.la for non-cygwin based shared library builds. * Makefile.am (libopcodes_la_DEPENDENCIES): Append SHARED_DEPENDENCIES. (libopcodes_la_LIBADD): Rename WIN32LIBADD to SHARED_LIBADD. (libopcodes_la_LDFLAGS): Rename WIN32LDFLAGS to SHARED_LDFLAGS. * configure: Regenerate. * Makefile.in: Regenerate.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 51602576673..c1defe03c43 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -367,10 +367,11 @@ libopcodes_la_SOURCES = dis-buf.c disassemble.c dis-init.c
# Unfortunately this causes libtool to add -L$(libdir), referring to the
# planned install directory of libbfd. This can cause us to pick up an
# old version of libbfd, or to pick up libbfd for the wrong architecture
-# if host != build.
-libopcodes_la_DEPENDENCIES = $(OFILES)
-libopcodes_la_LIBADD = $(OFILES) @WIN32LIBADD@
-libopcodes_la_LDFLAGS = -release `cat ../bfd/libtool-soversion` @WIN32LDFLAGS@
+# if host != build. So for building with shared libraries we use a
+# hardcoded path to libbfd.so instead of relying on the entries in libbfd.la.
+libopcodes_la_DEPENDENCIES = $(OFILES) @SHARED_DEPENDENCIES@
+libopcodes_la_LIBADD = $(OFILES) @SHARED_LIBADD@
+libopcodes_la_LDFLAGS = -release `cat ../bfd/libtool-soversion` @SHARED_LDFLAGS@
# libtool will build .libs/libopcodes.a. We create libopcodes.a in
# the build directory so that we don't have to convert all the