summaryrefslogtreecommitdiff
path: root/dejagnu/example/calc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'dejagnu/example/calc/configure.in')
-rw-r--r--dejagnu/example/calc/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/dejagnu/example/calc/configure.in b/dejagnu/example/calc/configure.in
new file mode 100644
index 00000000000..3ee022a441b
--- /dev/null
+++ b/dejagnu/example/calc/configure.in
@@ -0,0 +1,20 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.5)
+AC_INIT(calc.c)
+AC_CONFIG_HEADER(calc.h)
+CC=${CC-cc}
+
+#
+# Look for various header files
+#
+AC_HEADER_CHECK(stdlib.h, ,AC_DEFINE(HAVE_STDLIB_H))
+
+#
+# Look for various functions
+#
+AC_FUNC_CHECK(strcmp, AC_DEFINE(HAVE_STRCMP))
+
+#
+# Output Makefile with substitutions
+AC_SUBST(CC)
+AC_OUTPUT(Makefile)