summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 55ded716bf5..8435420a91a 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -92,6 +92,24 @@ AC_C_CONST
AC_CHECK_FUNCS(setpgid sbrk sigaction isascii bzero bcopy btowc poll sigprocmask)
AC_FUNC_ALLOCA
+dnl See if ptrace.h provides the PTRACE_GETXFPREGS request.
+dnl PTRACE_GETXFPREGS is a Cygnus invention, since we wrote our own
+dnl Linux kernel patch for SSE support. That patch may or may not
+dnl actually make it into the official distribution. If you find that
+dnl years have gone by since this configure test was added, and Linux
+dnl isn't using PTRACE_GETXFPREGS, that means that our patch didn't
+dnl make it, and you can delete this code.
+AC_MSG_CHECKING(for PTRACE_GETXFPREGS)
+AC_CACHE_VAL(gdb_cv_have_ptrace_getxfpregs,
+[AC_TRY_COMPILE([#include <sys/ptrace.h>],
+ [PTRACE_GETXFPREGS;],
+ [gdb_cv_have_ptrace_getxfpregs=yes],
+ [gdb_cv_have_ptrace_getxfpregs=no])])
+AC_MSG_RESULT($gdb_cv_have_ptrace_getxfpregs)
+if test $gdb_cv_have_ptrace_getxfpregs = yes; then
+ AC_DEFINE(HAVE_PTRACE_GETXFPREGS)
+fi
+
AC_CHECK_LIB(socket, socketpair)
AC_CHECK_FUNCS(socketpair)