summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index d7a2e12d910..da78509fc76 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -929,6 +929,19 @@ if test "${enable_gdbtk}" = "yes"; then
CY_AC_LOAD_TCLCONFIG
CY_AC_PATH_TKCONFIG
+ # now look for Tcl library stuff
+
+ case "${host}" in
+ *-*-cygwin*)
+ tcldir=../tcl/win/
+ ;;
+ *)
+ tcldir=../tcl/unix/
+ ;;
+ esac
+
+ TCL_DEPS="${tcldir}${TCL_LIB_FILE}"
+
# If $no_tk is nonempty, then we can't do Tk, and there is no
# point to doing Tcl.
if test -z "${no_tk}"; then
@@ -939,6 +952,20 @@ if test "${enable_gdbtk}" = "yes"; then
CY_AC_PATH_ITKH
CY_AC_PATH_TIXH
+
+ # now look for Tk library stuff
+
+ case "${host}" in
+ *-*-cygwin*)
+ tkdir=../tk/win/
+ ;;
+ *)
+ tkdir=../tk/unix/
+ ;;
+ esac
+
+ TK_DEPS="${tkdir}${TK_LIB_FILE}"
+
# now look for Itcl library stuff
CY_AC_PATH_ITCLCONFIG
@@ -1026,6 +1053,8 @@ fi
AC_SUBST(X_CFLAGS)
AC_SUBST(X_LDFLAGS)
AC_SUBST(X_LIBS)
+AC_SUBST(TCL_DEPS)
+AC_SUBST(TK_DEPS)
AC_SUBST(ITCLLIB)
AC_SUBST(ITCL_DEPS)
AC_SUBST(ITKLIB)