summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in35
1 files changed, 0 insertions, 35 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 2130aba4d37..12b5f6b9c13 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -986,41 +986,6 @@ GUI_CFLAGS_X="-I${srcdir}/../libgui/src"
AC_SUBST(LIBGUI)
AC_SUBST(GUI_CFLAGS_X)
-AC_ARG_WITH(cpu,
-[ --with-cpu=CPU Set the default CPU variant to debug],
-[case "${target}" in
- powerpc-* | powerpcle-* )
- ## It would be nice to keep this table in sync with the one in
- ## gcc/configure.
- case "${with_cpu}" in
- ppc-uisa | rs6000 | 403 | 403GC | 505 | 860 | 601 | 602 | 603 \
- | 604 | 750 )
- ## Those are all handled in variants in rs6000-tdep.c, so they're fine.
- ;;
- common | power | power2 | rios | rios1 | rios2 | rsc | rsc1 )
- ## These are all RS6000 variants, as far as GDB is concerned.
- with_cpu=rs6000
- ;;
- 603e | ec603e )
- with_cpu=603
- ;;
- 604e )
- with_cpu=604
- ;;
- * )
- AC_MSG_WARN(GDB: unknown --with-cpu value: \`${with_cpu}'; using \`ppc-uisa'.)
- with_cpu=ppc-uisa
- ;;
- esac
- ;;
- * )
- AC_MSG_WARN(GDB may ignore the --with-cpu flag for ${target} targets)
- ;;
-esac
-AC_DEFINE_UNQUOTED(TARGET_CPU_DEFAULT, "${with_cpu}")
-],)
-
-
AC_ARG_ENABLE(gdbtk,
[ --enable-gdbtk Enable GDBTK GUI front end],
[case "${enableval}" in