summaryrefslogtreecommitdiff
path: root/newlib/doc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/doc/configure.in')
-rw-r--r--newlib/doc/configure.in41
1 files changed, 41 insertions, 0 deletions
diff --git a/newlib/doc/configure.in b/newlib/doc/configure.in
new file mode 100644
index 00000000000..b116b3538cc
--- /dev/null
+++ b/newlib/doc/configure.in
@@ -0,0 +1,41 @@
+dnl This is the newlib/doc configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(makedoc.c)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../..)
+
+NEWLIB_CONFIGURE(..)
+
+# Put a plausible default for CC_FOR_BUILD in Makefile.
+if test -z "$CC_FOR_BUILD"; then
+ if test "x$cross_compiling" = "xno"; then
+ CC_FOR_BUILD='$(CC)'
+ else
+ CC_FOR_BUILD=gcc
+ fi
+fi
+AC_SUBST(CC_FOR_BUILD)
+
+# Also set EXEEXT_FOR_BUILD.
+if test "x$cross_compiling" = "xno"; then
+ EXEEXT_FOR_BUILD='$(EXEEXT)'
+else
+ AC_CACHE_CHECK([for build system executable suffix], newlib_cv_build_exeext,
+ [cat > ac_c_test.c << 'EOF'
+int main() {
+/* Nothing needed here */
+}
+EOF
+ ${CC_FOR_BUILD} -o ac_c_test am_c_test.c 1>&5 2>&5
+ newlib_cv_build_exeext=`echo ac_c_test.* | grep -v ac_c_test.c | sed -e s/ac_c_test//`
+ rm -f ac_c_test*
+ test x"${newlib_cv_build_exeext}" = x && newlib_cv_build_exeext=no])
+ EXEEXT_FOR_BUILD=""
+ test x"${newlib_cv_build_exeext}" != xno && EXEEXT_FOR_BUILD=${newlib_cv_build_exeext}
+fi
+AC_SUBST(EXEEXT_FOR_BUILD)
+
+AC_OUTPUT(Makefile)