summaryrefslogtreecommitdiff
path: root/newlib/libc/machine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/Makefile.am')
-rw-r--r--newlib/libc/machine/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/newlib/libc/machine/Makefile.am b/newlib/libc/machine/Makefile.am
new file mode 100644
index 00000000000..8157e9aae8c
--- /dev/null
+++ b/newlib/libc/machine/Makefile.am
@@ -0,0 +1,23 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+SUBDIRS = $(machine_dir) .
+
+if HAVE_MACHINE_DIR
+MACHLIB = lib.a
+endif
+
+noinst_LIBRARIES = $(MACHLIB)
+
+lib.a: $(machine_dir)/lib.a
+ rm -f $@
+ ln $(machine_dir)/lib.a $@ >/dev/null 2>/dev/null || \
+ cp $(machine_dir)/lib.a $@
+
+$(machine_dir)/lib.a:
+
+doc:
+
+ACLOCAL_AMFLAGS = -I ../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host