summaryrefslogtreecommitdiff
path: root/newlib/libc/reent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/reent/Makefile.am')
-rw-r--r--newlib/libc/reent/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/newlib/libc/reent/Makefile.am b/newlib/libc/reent/Makefile.am
new file mode 100644
index 00000000000..20baf3f2496
--- /dev/null
+++ b/newlib/libc/reent/Makefile.am
@@ -0,0 +1,55 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+noinst_LIBRARIES = lib.a
+
+lib_a_SOURCES = \
+ closer.c \
+ reent.c \
+ impure.c \
+ execr.c \
+ fstatr.c \
+ linkr.c \
+ lseekr.c \
+ openr.c \
+ readr.c \
+ signalr.c \
+ sbrkr.c \
+ statr.c \
+ timer.c \
+ writer.c
+
+CHEWOUT_FILES = \
+ closer.def \
+ reent.def \
+ execr.def \
+ fstatr.def \
+ linkr.def \
+ lseekr.def \
+ openr.def \
+ readr.def \
+ signalr.def \
+ sbrkr.def \
+ statr.def \
+ timer.def \
+ writer.def
+
+SUFFIXES = .def .h
+
+CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
+
+.c.def:
+ $(CHEW) < $< > $*.def 2> $*.ref
+ touch stmp-def
+
+TARGETDOC = ../tmp.texi
+
+doc: $(CHEWOUT_FILES)
+ cat $(srcdir)/reent.tex >> $(TARGETDOC)
+
+impure.o: $(srcdir)/impure.c $(srcdir)/../include/sys/reent.h
+
+CLEANFILES = $(CHEWOUT_FILES) *.ref