summaryrefslogtreecommitdiff
path: root/newlib/libc/sys/linux/machine/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/sys/linux/machine/configure.in')
-rw-r--r--newlib/libc/sys/linux/machine/configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/newlib/libc/sys/linux/machine/configure.in b/newlib/libc/sys/linux/machine/configure.in
new file mode 100644
index 00000000000..4b4933a2f3b
--- /dev/null
+++ b/newlib/libc/sys/linux/machine/configure.in
@@ -0,0 +1,34 @@
+dnl This is the newlib/libc/sys configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(i386)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../../../../..)
+
+NEWLIB_CONFIGURE(../../../..)
+
+dnl We have to enable libtool after NEWLIB_CONFIGURE because if we try and
+dnl add it into NEWLIB_CONFIGURE, executable tests are made before the first
+dnl line of the macro which fail because appropriate LDFLAGS are not set.
+if test "${use_libtool}" = "yes"; then
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+fi
+
+if test -n "${machine_dir}"; then
+ case ${machine_dir} in
+ i386) AC_CONFIG_SUBDIRS(i386) ;;
+ esac;
+fi
+
+CRT0=
+if test -n "${machine_dir}"; then
+ CRT0=crt0.o
+fi
+AC_SUBST(CRT0)
+
+AM_CONDITIONAL(HAVE_MACHINE_DIR, test x${machine_dir} != x)
+
+AC_OUTPUT(Makefile)