summaryrefslogtreecommitdiff
path: root/newlib/libc/time/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/time/Makefile.am')
-rw-r--r--newlib/libc/time/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/newlib/libc/time/Makefile.am b/newlib/libc/time/Makefile.am
new file mode 100644
index 00000000000..6909bf9cd3f
--- /dev/null
+++ b/newlib/libc/time/Makefile.am
@@ -0,0 +1,48 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+noinst_LIBRARIES = lib.a
+
+lib_a_SOURCES = \
+ asctime.c \
+ asctime_r.c \
+ clock.c \
+ ctime.c \
+ ctime_r.c \
+ difftime.c \
+ gmtime.c \
+ gmtime_r.c \
+ lcltime.c \
+ lcltime_r.c \
+ mktime.c \
+ strftime.c \
+ time.c
+
+CHEWOUT_FILES = \
+ asctime.def \
+ clock.def \
+ ctime.def \
+ difftime.def \
+ gmtime.def \
+ lcltime.def \
+ mktime.def \
+ strftime.def \
+ time.def
+
+SUFFIXES = .def
+
+CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
+
+.c.def:
+ $(CHEW) < $< > $*.def 2> $*.ref
+ touch stmp-def
+
+TARGETDOC = ../tmp.texi
+
+doc: $(CHEWOUT_FILES)
+ cat $(srcdir)/time.tex >> $(TARGETDOC)
+
+CLEANFILES = $(CHEWOUT_FILES) *.ref