summaryrefslogtreecommitdiff
path: root/newlib/libc/time/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/time/Makefile.am')
-rw-r--r--newlib/libc/time/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/newlib/libc/time/Makefile.am b/newlib/libc/time/Makefile.am
new file mode 100644
index 00000000000..7236a0a0440
--- /dev/null
+++ b/newlib/libc/time/Makefile.am
@@ -0,0 +1,70 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+LIB_SOURCES = \
+ asctime.c \
+ asctime_r.c \
+ clock.c \
+ ctime.c \
+ ctime_r.c \
+ difftime.c \
+ gettzinfo.c \
+ gmtime.c \
+ gmtime_r.c \
+ lcltime.c \
+ lcltime_r.c \
+ mktime.c \
+ mktm_r.c \
+ strftime.c \
+ strptime.c \
+ time.c \
+ tzlock.c \
+ tzset.c \
+ tzset_r.c \
+ tzvars.c
+
+libtime_la_LDFLAGS = -Xcompiler -nostdlib
+
+if USE_LIBTOOL
+noinst_LTLIBRARIES = libtime.la
+libtime_la_SOURCES = $(LIB_SOURCES)
+noinst_DATA = objectlist.awk.in
+else
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = $(LIB_SOURCES)
+lib_a_CFLAGS = $(AM_CFLAGS)
+noinst_DATA =
+endif # USE_LIBTOOL
+
+include $(srcdir)/../../Makefile.shared
+
+CHEWOUT_FILES = \
+ asctime.def \
+ clock.def \
+ ctime.def \
+ difftime.def \
+ gmtime.def \
+ lcltime.def \
+ mktime.def \
+ strftime.def \
+ time.def \
+ tzlock.def \
+ tzset.def
+
+SUFFIXES = .def
+
+CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
+
+.c.def:
+ $(CHEW) < $< > $*.def 2> $*.ref
+ touch stmp-def
+
+TARGETDOC = ../tmp.texi
+
+doc: $(CHEWOUT_FILES)
+ cat $(srcdir)/time.tex >> $(TARGETDOC)
+
+CLEANFILES = $(CHEWOUT_FILES) *.ref